back to Blog

SEARCH blog

search

Life Lessons with an Apprenticing Mechanic

Rookie in Blue

School Bus Mechanic

archive

School Bus Wiring Problem No Start

School Bus Wiring Problem No Start

05/06/2014

  • share



Thomas School Bus Wiring Troubleshooting

The pusher bus featured in the video is a 2000 Thomas Pusher (rear engine) bus that would not start from the ignition key. The wiring diagram indicated that the purple with a white stripe numbered #4 runs from the ignition key start terminal directly to a terminal board connection at the front access panel below the driver's side window.

From there it runs to another connection at the neutral start switch leading through the rear door switch then to the starter solenoid. After tracing the wiring to the back there was no #4 wire at all so we had to back track and get the bus on the hoist to physically locate this wire.

We knew that this circuit was hard wired 40 feet to the rear of the engine and thinking there was a neutral start switch it was directly connected to but in reality there is no actual neutral start switch on this bus. The Allison transmission wiring controls neutral start by way of a VIM vehicle interface module.

What Is A VIM?

This module is an interface between the transmission control unit and the bus chassis. The VIM not only controls neutral start using a relay but also controls high idle and the exhaust brake. The reason for this is the TCU sends a signal when it is in neutral so there is no damage when starting the engine. The same goes for high idle and exhaust brake.

Proceeding With Finding The Fault Wire

So we knew the neutral start circuit was working because we could start the engine from the back. The push button start at the back control panel also goes through the same switches as the ignition switch. That told us that there was an open circuit at the #4 purple wire with the white stripe. It was a 12 guage wire so it would be easy to locate and trace.

Once we found the wire in the harness along the frame we saved a lot of time running a new wire from the front and connected it to the existing wire half way down the bus. This was an easy decision since there was nothing but wiring from the switch to the rear of the bus. The problem was cured and that goes to show how very important having a schematic is to find an electrical problem.

I hope this helps anyone who comes across this same problem. There is no shame to running a new wire when it means saving a LOT of time trying to find the exact spot where the fault is located. Thank you for reading this post and leave a comment below with a question or a similar experience.

no comments
close

Thank you for signing up.

You have successfully created an account

COMPLETE YOUR PROFILE SEE YOUR DASHBOARD

are you sure you want to logout?

select

yes no

Reset Your password

Send Close
close
close

members only

Already a member? Please log in

Join The Hub

it's free and easy

SIGN UP now