2004 DT466E CRANKS, NO START

Mechanics Hub Forums Diesel Engines International (Navistar) 2004 DT466E CRANKS, NO START

This topic contains 18 replies, has 4 voices, and was last updated by  Shawn 1 year, 1 month ago.

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #48780 Reply

    Shawn

    I have a international 4300 with a dt466 and a auto trans truck cranks but will
    Not start changed the priming pump and still nothing

    #49493 Reply

    Jake B

    Hey, I have a 2007 International with a DT466. In the past few weeks I have replaced the primer pump, fuel lift pump, #2 Fuel injector and the crankshaft position sensor. I still cant get it to start. after replacing the fuel lift and primer pump plus injector. I got it running and it ran fine. let it run for two hours without a spudder. Then I tried hooking up to a trailer, and any time I gave it any throttle it wanted to stall out. I used to work at international but we had the software to diagnose these kinds of things. Now where I work I don’t have any. So I cant keep throwing parts at it. Any help would be awesome.

    #49656 Reply

    Frank

    My bus cranks but don’t start but when I put battery charger on it with then seconds it fires up

    #51456 Reply

    reginald scott floyd

    I did a inframe on my 2006 international dt466. Then engine started up fine and ran ok and just cut off and wont start back

    #51508 Reply

    Rick

    Crank no start replaced pump both, IPR, ICP, IDM, INJECTORS, wiring harness no oil pressure replaced oil regulator bypass valve thermo valve

Viewing 5 posts - 16 through 20 (of 20 total)
Reply To: 2004 DT466E CRANKS, NO START
Your information: