CAT D6 dozer

Mechanics Hub Forums Large Mining Equipment Dozers CAT D6 dozer

This topic contains 20 replies, has 6 voices, and was last updated by  Mechanics Hub 2 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #25721 Reply

    Hey everybody, man this seems like a cool website, its like a mechanic’s facebook! Anyways one of my D6 Dozers has a problem. I bet it’s something small and easy but i can’t figure it out because I don’t have the technical manual on hand. The hydraulic lock-out switch will not disengage and i cant figure out why. I checked all fuses and reset my circuit breakers. I thought it may be the pressure indicator for the seat but its not that either. Any advice is much appreciated.

    #28230 Reply

    Hi Josh,
    I have access to Cat svc. literature so maybe I can help you out. What is the serial number prefix on your machine? Usually those hydraulic lockout rocker switches on the dash console are backlight illuminated when activated. Is your’s staying illuminated regardless of switch position? Have you tested the switch? Usually you can gently pry the switch assemly up from its opening in the dash panel and then separate the switch from the harness for testing. Pay attention to the orientation of the switch terminals when you unplug it from the harness. I can research this a little more once I have your serial number prefix. Are there any other problems with your machine that might be related?

    #28231 Reply

    Here’s some general info on the hydraulic lockout system operation. Usually the lockout rocker switch is used to send electrical power to a solenoid. The lockout solenoid is usually located on a pilot manifold. The pilot manifold on a D6 is sometimes in the service oompartment, infront of the hydraulic tank, on the RH side of the cab. Often, there will be an accumulator mounted on the pilot manifold. Caution! The presence of an accumulator means that the pilot system can be pressurized for a while after engine is shut down. If you decide to remove the pilot lockout solenoid for inspection, make sure the accumulator is discharged. If you’re unsure of how to do this, ask someone knowledgable for help. The lockout solenoid needs to be energized in order for the pilot oil system to be unlocked so that you can use the hydraulics. When the electrical power to the solenoid is interrupted, either by the lockout switch or by a circuit fault, a spring inside the solenoid becomes dominant, and the solenoid plunger moves to achieve a locked mode, preventing the hydraulics from being actuated. One of my first diagnostic steps would be to measure electrical power at the lockout solenoid with the rocker switch in the unlock position. If there’s no electrical power at the solenoid, perform electrical continuity checks on the lockout switch. If there is power at the lockout solenoid, suspect a mechanical failure of the solenoid. If you have an inductive amp clamp available, measuring the current to the solenoid can be helpful. If there is power at the solenoid, my next diagnostic step would be to plumb a pressure guage into the pilot oil systrem downstream from the lockout valve. Also measuring the solenoid coil’s electrical resistance is recommended. If you have electrical power at the lockout solenoid and pilot pressure is zero downstream from the solenoid, the solenoid is faulty.

    If this is an electronic machine, there may be a machine control module in the circuit. The lockout rocker switch will provide an input signal to the control module. The control module will output a signal to the pilot lockout solenoid to energize it. If this is an electronic machine, and you have diagnostic software available to you, check for fault codes and you would be able to monitor the lockout switch status parameter on the computer to verify that the lockout switch is operating correctly.

    With the serial number prefix of your machine I will be able to provide more machine specific details to help with troubleshooting. Be safe.

    #28234 Reply

    Jim Owen
    Member

    Wow! I’m really impressed with your answers, Giles. Keep it up. I’ve just given you a click on the karma button.

    #28235 Reply

    Hey thanks alot everybody! Im currently not at my shop now, but i will post the serial # tomorrow morning when i get there. As far as the switch goes, i did test it and the switch is fine, i even tried it on another identical dozer and it worked fine for that one. This machine is electronic, and does have an ECM, and is popping code (Electronic IMPL #2 Abnormal Updates) and there is another code about changing the operation mode as well. Im gonna be furious if it is something extremely simple because i originally troubleshot it the old fashioned way, i dropped all the plates underneath and tried lookin for a possible solenoid for the lockout, but nothing was marked for it. Some plugs were tagged, but couldnt find one for it, and like i said i dont even have a tech manual so ive really been shootin in the dark so far. To tell you the truth i thought i might get lucky, but i was wrong haha. I basically concluded its something with the ECM, but after reading the one comment from Giles about the possible solenoid it gives me new hope because it seems i may have been on the right track after all. One other thing to keep in mind,…this dozer has 25.6 easy lived hours on her, so it also makes me think the brain just might have had a small seizure haha, i couldnt imagine a mechanical faliure taking place, this thing doesnt even have a scratch on her.

    #28238 Reply

    my serial # is NCF00027, Model is D6KXL, and CONTR # is SPM500-01-D-0059-0014.

    #28244 Reply

    Your pilot shutoff solenoid will be located on the outlet manifold (end cover) of your main control valve bank that is located at the rear of the machine, in front of the ripper. The solenoid will have a green wire labeled E918 and an orange wire labeled H706. You will probably have to drop your belly pan guard to access the control valve bank. Fault codes associated with the lockout solenoid will be identified as CID 0358 on your machine control module. To help identify your outlet manifold, your pilot system accumulator is also attached to this outlet manifold. If you have easy access to your machine control module it might be easier to start testing there. From what I can tell, your machine control module is on the LH side of the machine under a flip up door. Not sure if its inside the cab. The E918 green circuit from the solenoid connects to ECM connector J2 at terminal 2 at the ECM. Circuit H706 orange connects to terminal 4 of the connector J2 at the ECM. ECM connector J2 will be the lower of the two connectors and is located at the opposite end of the ECM from the large rectangular bulge in the face of the ECM housing. If you disconnect your pilot lockout solenoid from the harness and measure the voltage across the two harness wires you should measure 2.5V being output from the ECM, with the bottom of the lockout switch pressed (hydraulics unlocked) and key on. This test will cause a 0358-03 fault code to set so you will have to clear it when done troubleshooting. Also, I noticed on the hydraulic schematic, that there was a pressure test tap connected to the outlet manifold for measuring pilot pressure downstream from the lockout solenoid. It might be a remote mounted pressure tap. If you have pressure guages this might be helpful. Good luck.

    #28248 Reply

    karce
    Member

    can you check the system by monitor for codes or service code?
    you can check it on the monitor or messenger display (if there is equipped)on the right site
    If you have code “electronic IMPL control module abnormal update rate” you can check suply voltage,ground and data link.(maybe change SW version by et)If all is ok maybe the module is dead.Some machine had problem with modul.

    #28254 Reply

    i found that solenoid, i had to take everything our of the cab and the floorboards to get to it, and its still out of sight, but i could unplug it and verify the wire numbers. i replaced what the CAT guy that came thought was the secondary ECM and weirdly the switch and everything worked….for about 30 seconds. i tried using the blade, was lifting it off the ground and worked but then the lock turned on and that same code popped. Electronic IMPL Control 2 , Abnormal Update. 1558-9. i dont know where this 2nd ECM is because no manuals and the thing i thought it was is just for the ripper apparently.

    #28257 Reply

    karce
    Member

    Hi I found this…The 300-3631 slave ECM control group may fail on certain D6K XL Track-Type Tractors. When the slave ECM control group fails, the blade angling function may not operate, implements do not work and/or implements work in only one direction. The following diagnostics code(s) may be logged:

    CID FMI
    1558 09
    2143 09

    The prefix of serial number is different from your but all machines are D6K.Maybe it help you.
    I think (or I am afraid) that you will be to need et to diagnostic and replacing ECM slave.
    The ecm 2 (slave) should be at the batteries compartment (on the top compartment).

    We had same problem on D6K 🙁

    You can download some information: https://rapidshare.com/files/2234908319/schematic_D6K.pdf
    https://rapidshare.com/files/2274566266/testing.pdf

    Good luck 🙂

    #28258 Reply

    Yup those are the two codes im poppin’. Must be that slave ECM because I checked the other possibilities and it wasn’t fun either but I wanted to make sure it wasnt something little like a bad harness or cut wires somewhere. Another tough one shootin’ in the dark with no manuals. Thanks to everybody for all the great advice. I have a CAT rep coming out again so hopefully with my input from what i’ve learned from you all we can get this thing figured out quicker.

    #28278 Reply

    Still haven’t pinpointed the problem. The CAT tech thinks it is a problem somewhere with the data link and in the communication between the ECMs and the displays. Hopefully we can get some luck, he is coming out again sometime this week.

    #28370 Reply

    The problem was the Implement ECM needed to be updated with a new version of it. The first models had some problems (like i had) and they changed the entire ECM , that was the issue, its a shame CAT wasn’t as aware about that because it could have saved myself and the CAT techs alot of time and effort.

    #28394 Reply

    karce
    Member

    Hi..good news :-)..

    #47408 Reply

    Daniel Quinones

    Hey guys im having a similar issue with a dozer but im getting faults 4215-31 and 1558-9 i am trying to troubleshoot them but not entirely sure where to start i know one is for ground level but not sure what it needs found some broken wiring and repaired it but issue is still here

Viewing 15 posts - 1 through 15 (of 21 total)
Reply To: CAT D6 dozer
Your information: